Gentoo - install Ruby 1.9.2 - resolve problems with ruby_targets_ruby19

Gentoo - install Ruby 1.9.2 - resolve problems with ruby_targets_ruby19

Lastly I faced problems with installing Ruby 1.9 on Gentoo distros. First I unmasked Ruby 1.9.2 version. I use for that autounmask tool:

# autounmask =/dev-lang/ruby-1.9.2

But after that I received error on rdoc installation:

# emerge ruby
emerge: there are no ebuilds to satisfy ">=dev-ruby/rdoc-2.5.11[ruby_targets_ruby19]". (dependency required by "dev-lang/ruby-1.9.2" [ebuild]) (dependency required by "ruby" [argument])

How to resolve that problem and install Ruby 1.9?

First you should add ruby19 RUBY_TARGETS in /etc/make.conf

(add line in /etc/make.conf)
RUBY_TARGETS="ruby18 ruby19"

Then unmask Ruby target for 1.9 version (really strange):

# echo "-ruby_targets_ruby19" >> /etc/portage/profile/use.mask

After that you need to run again autounmask tool for unmasking all needed packages for added target Ruby 1.9:

# autounmask =dev-lang/ruby-1.9.2

I know that this is very unintuitive but it's how things working now in portage for USE flags unmasking. That all you should have Ruby 1.9 installed and ready to work.

Comments

Symona

Symona wrote

BION I'm imeprssed! Cool post!

xxxx

xxxx wrote

Hi,

is 1.9.2 gonna work with passenger that way?

Comment