Blog

How to resolve "Cannot mount ext4 filesystem" problem?

After last kernel update I have run into problems with starting system. My computer cannot start the system with new compiled kernel version. Only thing that I changed was root partition type. I've changed it from ext3 to ext4 filesystem. When I tried to run system with new kernel I receive this message:

mount: cannot remount block device /dev/sda2 read-write, is write-protected
 

Resolution

dmesg gives the answer, it says:

EXT4-fs (sda2): Filesystem with huge files cannot be mounted RDWR without CONFIG_LBDAF 

You need to compile your kernel with "Support for large (2TB+) block devices and files" enabled (CONFIG_LBDAF option in kernel config).


Release of Cyrus IMAPd 2.4.9beta2

There is new Cyrus IMAPd 2.4.9beta2 version available to download.You can download it from the snapshots directory: This is an beta release in the 2.4.x series. It fixes couple of bugs in the "deliver" and lmtp codepaths and adds a couple of wishlist items. It also reverts the LMTP delivery fix for Bug #3163, which was implicated in Sieve issues at FastMail.

WARNING! One known bug that still exists is that quota -f can cause ALL quotaroots to believe they have twice their actual usage. This bug is still present in 2.4.9beta2 as well as beta1. This problem has always existed, but is much worse because of a bug in 2.4.8 where user renames caused quotaroots to become incorrect. The recommended workaround at this time is to run quota -f TWICE any time you need to run it. The first run should fix any incorrect quota roots, and the second run will fix all the doubled quotas caused by the first one.

3 commonly used ways to find Ubuntu version that you have

Have you ever forgotten which Ubuntu version you are using? If it's true here you will find methods how to check Ubuntu version that you are curently running.

Simplest ways to find Ubunt version:
 

1. Use lsb_release command

Simply run from command line:
  lsb_release -a

2. Find Ubuntu version inside /etc/issue file

Simply edit or cat issue file like below:
  cat /etc/issue

3. Check ubuntu version in lsb-release file

  cat /etc/lsb-release
Those are most commonly used ways to check Ubuntu version which your system is running from the command line level.

How to install mongodb 1.8 on Ubuntu 10.04 Lucid LTS?

Here you have quick installation guide for mongodb on Ubuntu 10.04: Edit:

echo "deb http://downloads-distro.mongodb.org/repo/ubuntu-upstart dist 10gen" >> /etc/apt/sources.list
apt-get update
apt-get install mongodb-10gen

Remember that Debian-like systems and default package configuration aren't often security aware so you should edit mongodb config:

vim /etc/mongodb.conf

and add line:

bind_ip 127.0.0.1

This will disable default setting to run mongodb in trusted mode

How to check if processor is 32 bit or 64 bit?

You can check the long mode processor flag:

# grep lm /proc/cpuinfo
flags : fpu de tsc msr pae mce cx8 apic sep mtrr mca cmov pat clflush acpi mmx fxsr sse sse2 ss ht syscall nx lm constant_tsc rep_good nonstop_tsc aperfmperf pni pclmulqdq est ssse3 cx16 sse4_1 sse4_2 popcnt aes hypervisor lahf_lm ida arat

 

If you have lm flag (like above) your CPU is at 100% 64 bit


Gentoo - install Ruby 1.9.2 - resolve problems with ruby_targets_ruby19

Gentoo - install Ruby 1.9.2 - resolve problems with ruby_targets_ruby19

Lastly I faced problems with installing Ruby 1.9 on Gentoo distros. First I unmasked Ruby 1.9.2 version. I use for that autounmask tool:

 # autounmask =/dev-lang/ruby-1.9.2

But after that I received error on rdoc installation:

 # emerge ruby emerge: there are no ebuilds to satisfy ">=dev-ruby/rdoc-2.5.11[ruby_targets_ruby19]". (dependency required by "dev-lang/ruby-1.9.2" [ebuild]) (dependency required by "ruby" [argument]) 

How to resolve that problem and install Ruby 1.9?